[Answered] Unable to register a (particular) book

Forum » Site Questions: Basic and Advanced | Refresh | Search

Sort Options 

Complete Thread
I’m trying to register a book, and having no luck. Last night I tried several times only to be told it doesn’t show up in the database. It’s from a small press, so I looked it up online and found it carried and reviewed multiple places, including Amazon. Thinking maybe it was a temporary glitch, I decided to wait till this morning and try again Which I did- still not in database. I tried skip search, and that gives me an error message. Tried multiple times. Help, please! Is there anything else to try! Tia!

 

What was the title? Once in a while I'll run into a registration error in which it seems the registration did not take, only to have the book appear on my shelf later. [I have noticed that if the ISBN lookup fails and I then switch to the skip-search function, I see an error message even though the registration works; it's as if the failure to find the ISBN sets a flag somewhere that doesn't get cleared by the skip-search button.]

If the book's still not showing, I'd suggest trying again, starting with the skip-search option this time, and making sure to fill in all the fields. Or - and this is a bit sneaky - use the ISBN from some other book to get the registration going, and once it's all done, edit the book details to change them to match your book.

 

I tried skip search, and that gives me an error message. Tried multiple times.

Be sure to check your shelf... sometimes, the error message comes up but the book is registered nonetheless. Just a heads up!

 

erishkigal 9 mos ago
Thanks
Checked my shelf; not there. Tried again skipping search; error again. I’v got a meeting to get to, when I get home I’ll use the sneaky work-around. Thanks!

 

Are you sure you want to delete this item? It cannot be undone.