corner corner Regsitering book trouble: "This value is required" though I have filled in the fields

Forum | << Site Questions: Basic and Advanced | Refresh | Search

corner corner

Sort Options Toggle Stats Options


Profile Image

Regsitering book trouble: "This value is required" though I have filled in the fields

I am trying to registering a book and getting always the same error:

Skip search -> Filling title, author, etc. all fields, but seeing anyway in the bottom of the page many red "this value is required" warnings. [1]
Then if I hit "Register book" I get the error "Sorry, there was a problem processing your request. Please recheck your input and try again." [2]

I am using both Chromium and Firefox on linux (in case this is important) and getting same error.

Note that it is absurd in [1] to see warnings though the fields are filled in and in [2] to get this general-purpose error with no more info that actually does not help.

Complete Thread

Profile Image
I am trying to registering a book and getting always the same error:

Skip search -> Filling title, author, etc. all fields, but seeing anyway in the bottom of the page many red "this value is required" warnings. [1]
Then if I hit "Register book" I get the error "Sorry, there was a problem processing your request. Please recheck your input and try again." [2]

I am using both Chromium and Firefox on linux (in case this is important) and getting same error.

Note that it is absurd in [1] to see warnings though the fields are filled in and in [2] to get this general-purpose error with no more info that actually does not help.
Profile Image
If this is happening to one particular book, perhaps you could post the ISBN/title/author; that shouldn't make a difference, but sometimes it does. (I don't think Linux would be a problem, and while I've seen reports of problems with Chrome, Firefox should work - that's what I use, though on Windows.)

Once in a while I've run into a situation where the category I chose didn't seem to stick, and I got a "field not filled in" message because of that, but that's very, very rare.

I haven't had any trouble registering books recently, though I have noticed that if I tried an ISBN-lookup that did not find the book I wanted, and then went on to the "skip search" option, I would sometimes see an error message at the top of the book-details screen - looked as if it was a holdover from the previous "could not find" option. It didn't cause any problems with the actual registration, though.
Profile Image
perhaps you could post the ISBN/title/author

I skip the search and then I type them myself.
They are in Greek! ;-) Here they are, in case it makes a difference:
Title: Φόβος κανένας - 29 μικροδιηγήματα
Author: Γιάννης Φάρσαρης
ISBN: 978-618-81465-1-8
Description field: <<long text still in Greek>>

I get 4 red warnings "This value is required." at the bottom of the page.
Three of them are for the title, author and Category (each field has a red asterisk at the right side), but all of which I have filled. I can see the text I 've filled in.
The source field of the fourth error is unidentified.
I get no error for the ISBN field.

Whatever I type in the author and title fields, I still see the errors. Tried with latin characters as well, just in case. In addition to that, whatever I select in the categories, I still get the error.

P.S.: I checked my profile, just in case that the book is already registered despite the error. But it isn't. At least, it does not show up in my registered books.
Profile Image
Hmmm. What kind of book is it? I'm getting no hits, whether on the ISBN (minus hyphens) or on the title/author (in Greek or Google-translated).

You *might* try using the "skip search" page and omitting the ISBN, just filling in the title/author/category fields; if there's some problem with the ISBN that might affect the registration.

Also, you refer to a "long" description field; perhaps you could try registering the book with a minimal JE at first - the equivalent of "Found it at the (mumble) store" or whatever. If you can get the registration to work, you can then try editing the book-details and/or the journal entry to expand the information.
Profile Image
You *might* try omitting the ISBN
...and doing a minimal register

This worked!
Writing "asdf" in all required fields and nothing more. ISBN is _not_ a required field.
I then edited all book details successfully.

I suspect that there was something wrong on the ISBN. Maybe the hyphens were the problem. I am too bored to test again, now that it worked.

However, it is still not nice that:

* I never got any clear message about what the error was. "There was a problem processing your request" is bullshit. No real information provided.

* The red dots for the required fields are misleading. They mean "you have to type here" but are visible even AFTER you type. So, I thought that the page did not accept what I typed.

I hope the site designers are reading here...
Profile Image
I hope the site designers are reading here...

Yes, I'll make sure Matt reads your message.
Profile Image
I don't know if this has any connection with your problem or not.

I have successfully registered books lately (I used pre-numbered labels, if that makes a difference, so you make a journal entry in order to register them), though several times I got the error message at the top of the page telling me it was not successful.

I decided to check before re-trying and in each case, the registration did go through, although the site was telling me it did not. So it worked, but the site thought it didn't.

It's a fairly new issue for me, since the recent upgrade, but since the books were registered properly, I probably didn't think to report it.
Profile Image
I just got the same kind of error message. I was trying to register a book using ISBN-lookup only to have the lookup return no result, odd as it was a valid and relatively recent ISBN. I switched to the "skip" option and filled in the fields, only to notice the "value required" messages appearing. I made sure I *had* filled in all the fields and then clicked the "register" button anyway, and the registration went through successfully - though it didn't pick up a cover-pic, presumably for the same reason the initial ISBN-lookup didn't get a hit. [I *was* able to find a matching cover using the "update cover" feature, though that begs the question of why the ISBN wasn't found.]

The result of all this suggests to me that the error messages might be bogus. If you haven't already tried to proceed with the registration, give it a shot - just do make sure that all the fields have valid values (except possibly the ISBN, which isn't necessary and which can be filled in later). If you click on the "register" button and the registration still doesn't go through, then your problem's different from the one I observed; worth a shot, anyway!

The site shouldn't display bogus error messages, of course, but it can be tough getting the error-detection code to the right level of sensitivity.

Are you sure you want to delete this item? It cannot be undone.